BAD!!! Oil Leak!!!

post questions about your car

BAD!!! Oil Leak!!!

Postby BAJA1971 » Thu Oct 28, 2010 12:47 pm

I have a oil leak coming from behind my crank pully. i vented the valve covers using the bug pack oil breather kit. i thought that would help, it did a little bit! lol! My engine is a 1641 with a W110 cam. It does have a high volume oil pump


Any advise on what will or how to fix it would be GREAT!!
Thanks,
Random avatar
BAJA1971
 
Posts: 10
Joined: Sun Oct 24, 2010 1:07 am

Re: BAD!!! Oil Leak!!!

Postby vdubjim » Thu Oct 28, 2010 11:17 pm

Breather on the oil filler blocked?

too much oil psi?
User avatar
vdubjim
Site Admin
 
Posts: 2019
Joined: Fri Aug 28, 2009 10:21 am

Re: BAD!!! Oil Leak!!!

Postby BAJA1971 » Fri Oct 29, 2010 1:12 am

AAHHH! found it!! it was coming from around my fuel pump!! thats weird! live and learn!!! Thanks for the reply Jim!
Random avatar
BAJA1971
 
Posts: 10
Joined: Sun Oct 24, 2010 1:07 am

Re: BAD!!! Oil Leak!!!

Postby BAJA1971 » Sun Nov 14, 2010 10:47 am

Well looks like the motor has got some serious issues!! I dropped it off to one of the guys there at Bethany Imports..... hope they can figure out what the problem is!!! lol!

Hey Jim where you guys located in OKC?
Random avatar
BAJA1971
 
Posts: 10
Joined: Sun Oct 24, 2010 1:07 am

Re: BAD!!! Oil Leak!!!

Postby vdubjim » Sun Nov 14, 2010 2:29 pm

like what??

we are all over. im in choctaw.
User avatar
vdubjim
Site Admin
 
Posts: 2019
Joined: Fri Aug 28, 2009 10:21 am

Re: BAD!!! Oil Leak!!!

Postby BAJA1971 » Sun Nov 14, 2010 3:56 pm

well the motor started to ummm... make some un-natural noise!! lol! Then it locked up!!! There was oil in it and I always checked it before i drove it , just cause it leaked oil.... man it couldnt have come at a worse time either! I miss driving my booger green baja! lol!

Choctaw!!! hell i grew up in MWC!! I live out in western Okla. in a town called Burns Flat
Random avatar
BAJA1971
 
Posts: 10
Joined: Sun Oct 24, 2010 1:07 am

Re: BAD!!! Oil Leak!!!

Postby vdubjim » Sun Nov 14, 2010 4:26 pm

sorry to hear that!

Ive heard of burns flat. I bet not too many vw out there?
User avatar
vdubjim
Site Admin
 
Posts: 2019
Joined: Fri Aug 28, 2009 10:21 am

Re: BAD!!! Oil Leak!!!

Postby BAJA1971 » Sun Nov 14, 2010 5:47 pm

lol nope not to many. 3 bugs and my baja out here. a lil old lady drives a light colored purple one, a guy were my wife banks just got his restored, and a kid that has a red one, who knows a bit more about them than i do! lol! I wish i had another 1600dp that was broke down, that way i could take it apart and see its internal workings...
Random avatar
BAJA1971
 
Posts: 10
Joined: Sun Oct 24, 2010 1:07 am


Return to Tech Help

cron
Hosted by Freeforum.ca, get your free forum now! TOS | Support Forums | Report a violation
buying traffic website
MultiForums powered by echoPHP phpBB MultiForums